Upcoming Status Page Transition


On April 26, 2026, starting at 11:00 AM ET, products will transition from this status page to a single consolidated status page. The transition is expected to take 1–2 hours.


All products will be available at https://status.optum.com, except Pharmacy products, which will transition at a later date. Thank you for your patience as we improve service visibility.

Resolved notice - ACCUREG - ENGAGECARE PROVIDER - EngageCare Provider users are unable to login to the application intermittently

Incident Report for Optum Solutions

Resolved

The login issues for EngageCare Provider are now resolved. If you have any further issues, please open Customer Care Hub Support Request.

INC #INC49002906
Posted Mar 18, 2026 - 14:39 EDT

Monitoring

We continue to monitor the issue and teams remain actively engaged. Further updates will be provided as available.
Posted Mar 18, 2026 - 11:13 EDT

Investigating

We are aware that customers may not be able to login to EngageCare Provider. Our teams are actively working to troubleshoot and resolve the issue.

INC #INC49002906
Posted Mar 18, 2026 - 09:56 EDT
This incident affected: Patient Financial Clearance (EngageCare Provider).