Status Page Transition Complete


As of April 26, 2026, all applicable products have successfully transitioned to a single, consolidated status page to improve service visibility and consistency.


All products are now available at https://status.optum.com, except Pharmacy products, which will transition at a later date. We appreciate your patience as we continue to enhance our status and communication experience.

Resolved Notice: RXNS CARDFINDER REAL-TIME CHC- Optum insight was experiencing intermittent timeouts with Cardfinder Eligibility checks.

Incident Report for Optum Solutions

Resolved

The issue causing intermittent timeouts with our Cardfinder service have been resolved and the service is no longer experiencing any timeouts. Thank you for your patience while we worked through this issue.

INC #INC50569042
Posted Jun 16, 2026 - 12:35 EDT

Investigating

We have identified intermittent timeouts occurring with our Cardfinder service and are working to resolve the issue. We will send an update once there is any new information or a resolution.


INC #INC50569042
Posted Jun 16, 2026 - 12:17 EDT
This incident affected: Pharmacy Network Solutions.