For further updates about the Change Healthcare cybersecurity issue, please visit Change Healthcare Cyber Response.

For imaging solutions, please visit us at Change Healthcare Enterprise Imaging.

New Incident: AHI performance issue
Incident Report for Optum Solutions
Resolved
This incident has been resolved.
Posted Sep 27, 2024 - 09:06 EDT
Investigating
Optum is experiencing issues with AHI and Lobby after last night's release.

This may result in:
- Users not having the same permissions as previously setup

Support is working on resetting all user roles as a work around until the permanent fix is put into place. Please log out and back in to see your normal permission views.

INC 0617817
Posted Sep 18, 2024 - 13:59 EDT
This incident affected: Revenue Cycle Management (Ahi Lobby, AhiQA).