The service disruption previously reported has been resolved. The ability to validate NPI within Enrollment Central/Provider Management is restored. We appreciate your patience during this brief interruption.
Posted Dec 18, 2025 - 20:55 EST
Identified
We are aware of a service disruption that may temporarily impact your ability to validate NPI within Enrollment Central/Provider Management. We are working to ensure this is resolved as quickly as possible and we appreciate your patience.
Posted Dec 18, 2025 - 19:08 EST
Update
We are aware of a service disruption that may temporarily impact your ability to process new enrollments on Enrollment Central. We are working to ensure this is resolved as quickly as possible and we appreciate your patience.
INC/CSA/Ref #INC47279556
Posted Dec 18, 2025 - 18:48 EST
Investigating
We are aware of a service disruption that may temporarily impact your ability to process new enrollments on Enrollment Central. We are working to ensure this is resolved as quickly as possible and we appreciate your patience.
INC/CSA/Ref #INC47279556
Posted Dec 18, 2025 - 18:30 EST
This incident affected: Medical Network (Batch, Real Time).