Welcome to our new simplified view of this Optum Solution Status page making it easier for you to quickly get the information you need.

Resolved Notice : CLINICAL EXCHANGE - Some users not able to reach Clinical Exchange

Incident Report for Optum Solutions

Resolved

An issue with some end‑users experiencing errors while attempting to access the Clinical Exchange application has been resolved. We are continuing to monitor.

INC# INC48666477
Posted Feb 27, 2026 - 09:28 EST

Investigating

We are aware of an issue with end-users experiencing errors while trying to access the Clinical Exchange application. We are investigating this as a priority.


INC# INC48666477
Posted Feb 27, 2026 - 08:47 EST
This incident affected: Clinical Exchange.