Status Page Transition Complete


As of April 26, 2026, all applicable products have successfully transitioned to a single, consolidated status page to improve service visibility and consistency.


All products are now available at https://status.optum.com, except Pharmacy products, which will transition at a later date. We appreciate your patience as we continue to enhance our status and communication experience.

Resolved Notice - RXN ENTERPRISE PHARMACY SYSTEM (CHC) - Certificate Expired Exception

Incident Report for Optum Solutions

Resolved

The workaround given has resolved the issue where it has been applied. The rollout to stores is continuing and expected to be complete within the next hour.


#INC49821636
Posted May 04, 2026 - 14:20 EDT

Monitoring

The workaround has proved successful when applied. We are continuing to monitor until completion.


#INC49821636
Posted May 04, 2026 - 13:21 EDT

Update

A workaround has been found for the issue, and is being communicated via your support team.


#INC49821636
Posted May 04, 2026 - 13:15 EDT

Investigating

We are aware of an issue with a certificate expiration causing major impact to your business. Our teams are currently engaged and will provide an update as it becomes available.


#INC49821636
Posted May 04, 2026 - 12:27 EDT
This incident affected: Pharmacy Software Solutions.