Optum continues to work towards identifying the issue.
Next update at 7 p.m. ET or as further information becomes available.
Posted Dec 10, 2024 - 16:59 EST
Update
Optum continues to investigate this issue.
Next update will be at 5 p.m. ET or when further information becomes available.
Posted Dec 10, 2024 - 16:00 EST
Update
We are continuing to investigate this issue.
Posted Dec 10, 2024 - 15:42 EST
Investigating
This notification is intended for Pharmacy Network Services customers.
This notification is to inform customer billing claims to BIN 024532 that Optum Insight has identified an issue causing the Pharma buy-down program to not apply. This issue is resulting in erroneously high patient pay amounts.
Optum is working to investigate and resolve the issue.
Next update will be at 4 p.m. ET or as further information becomes available.
INC 0662100
Posted Dec 10, 2024 - 15:34 EST
This incident affected: Pharmacy Solutions (Rx Assist).