For further updates about the Change Healthcare cybersecurity issue, please visit Change Healthcare Cyber Response.

For imaging solutions, please visit us at Change Healthcare Enterprise Imaging.

Resolved Incident: Clearance experiencing performance issue

Incident Report for Optum Solutions

Resolved

This incident has been resolved.
Posted Mar 20, 2025 - 14:14 EDT

Investigating

Clearance is experiencing an issue with Medical Necessity. This may result in the following error when using code finder:

Web Service Failed! The remote server returned an error: (441).

We are working on a resolution and will keep you posted as additional information is available.

REF 16943508
Posted Mar 20, 2025 - 11:47 EDT
This incident affected: Revenue Cycle Management (Clearance Patient Access Suite: Medical Necessity).