The cloud fare issue has been resolved and services are available. Thank you for your understanding and patience as we worked to resolve this matter.
#INC46998736
Posted Dec 05, 2025 - 05:50 EST
Investigating
We are aware of an issue involving Medical Network Real time and RCM ASSURANCE . Our teams are currently working closely to minimize any impact and restore services. We appreciate your patience as we work to resolve this issue as quickly as possible
#INC46998736
Posted Dec 05, 2025 - 05:47 EST
This incident affected: Revenue Cycle Management (Assurance Reimbursement Management) and Medical Network (Real Time).