Welcome to our new simplified view of this Optum Solution Status page making it easier for you to quickly get the information you need.

Resolved Notice- MEDRX AZURE- claim processing issues

Incident Report for Optum Solutions

Resolved

MedRx previously experienced claim processing issues related to pharmacy number rejections within the Medicare Vaccine program. The issue has been fully investigated and resolved. All impacted claims have been addressed, and normal processing has resumed.
Posted Nov 28, 2025 - 12:32 EST

Investigating

MedRx Optum Insight is currently encountering claim processing issues specifically related to pharmacy number rejections within the Medicare Vaccine program. The issue is actively being investigated by our team. We are committed to resolving the problem and will provide an update as soon as more information becomes available.

#INC46878007
Posted Nov 28, 2025 - 10:49 EST
This incident affected: Pharmacy Solutions (MedRx).