For further updates about the Change Healthcare cybersecurity issue, please visit Change Healthcare Cyber Response.

For imaging solutions, please visit us at Change Healthcare Enterprise Imaging.

Resolved: SmartPay Plus Experiencing Issue Affecting Daily Reports

Incident Report for Optum Solutions

Resolved

This incident has been resolved.
Posted Mar 13, 2025 - 10:25 EDT

Investigating

SmartPay Plus is experiencing an issue affecting daily reports. We are actively engaged in determining the scope and implementing a fix.

We understand the importance of these reports to your operations and are working diligently to resolve the issue as quickly as possible. An updated notification will be sent once the issue is resolved.

REF 16784608
Posted Mar 10, 2025 - 13:21 EDT
This incident affected: Provider Communications and Payment Services (SmartPay Plus for Providers).