Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 12, 2024 - 21:00 EDT
Scheduled
The InterQual® Coordinated Care Production environments will be unavailable due to maintenance Thursday, Sept. 12, 2024, 9:00 p.m. ET for approximately 1 hour. Users do not need to take any action but should stop their work before 9:00 p.m. ET or their session will be interrupted.
We appreciate your support and apologize for any inconvenience this may cause.
Updated Maintenance Schedule Begin: Sept. 12, 2024, 9:00 p.m. ET End: Sept. 12, 2024, 10:00 p.m. ET
Contact Information For any additional information or assistance, log onto the Customer Care Hub and submit a new case to Product Support.
REF 775702
Posted Sep 11, 2024 - 14:52 EDT
This scheduled maintenance affected: Clinical Decision Support (InterQual® Coordinated Care).