For further updates about the Change Healthcare cybersecurity issue, please visit Change Healthcare Cyber Response.

For imaging solutions, please visit us at Change Healthcare Enterprise Imaging.

Resolved : Clearance Patient Access Suite: Verifier

Incident Report for Optum Solutions

Resolved

We are pleased to inform you that the issue affecting the Clearance Patient Access Suite: Verifier has been resolved. Thank you for your patience and understanding while we worked to resolve this matter. If you continue to experience any issues, please do not hesitate to contact our support team.
Posted Mar 29, 2025 - 16:16 EDT

Identified

Issue is still the same occurring. Team is currently working to resolve this issue.
Posted Mar 29, 2025 - 15:43 EDT

Investigating

New incident: Clearance Patient Access Suite: Verifier is not performing as expected.
03/29/2025  02:40PM ET

This message is intended for Clearance Patient Access Suite: Verifier
Clearance Patient Access Suite: Verifier customers are currently experiencing issues with Receiving payer unavailable responses for eligibility transactions. Will provide further updates as they are available. We apologize for the inconvenience this situation has caused you.

#INC0704383
Posted Mar 29, 2025 - 14:48 EDT
This incident affected: Revenue Cycle Management (Clearance Patient Access Suite: Verifier).