Welcome to our new simplified view of this Optum Solution Status page making it easier for you to quickly get the information you need.

Resolved: Rx Connect issue

Incident Report for Optum Solutions

Resolved

The processor, Freedom, has resolved this issue and BIN 0077895 is performing as expected.
Posted Jul 17, 2025 - 12:29 EDT

Monitoring

This message is intended for Optum Insight Rx Connect clients

Please be advised that BIN 007895 has been having intermittent issues today, July 16, 2025. The processor, Freedom, is aware of the issue and working with their vendor partners to resolve it.

Optum is monitoring the situation.
Posted Jul 16, 2025 - 17:27 EDT
This incident affected: Pharmacy Solutions (Pharmacy Network Solutions).