Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 30, 2025 - 14:00 EDT
Update
Date Identified: June 30th, 2025
On June 30th, starting at 2 p.m. EST we will again test the production environment’s IP addresses.
Thank you for your patience and understanding as we strive to improve the payment integrity and security of the SmartPay Plus Platform. Users can expect minimal interruption while using the SmartPay Plus application. If any interruptions occur, please contact our support analysts to report any issues or concerns. Should you have any questions, concerns, or encounter any ongoing issues, please do not hesitate to contact us at pbps_support_team@optum.com.
Users can expect minimal interruption while using the SmartPay Plus application. If any interruptions occur, please contact our support analysts to report any issues or concerns.
Best Regards,
SmartPay Plus Support
Posted Jun 27, 2025 - 13:00 EDT
Scheduled
Date Identified: June 30th, 2025
On June 30th, starting at 2 p.m. EST we will again test the production environment’s IP addresses.
Thank you for your patience and understanding as we strive to improve the payment integrity and security of the SmartPay Plus Platform. Users can expect minimal interruption while using the SmartPay Plus application. If any interruptions occur, please contact our support analysts to report any issues or concerns. Should you have any questions, concerns, or encounter any ongoing issues, please do not hesitate to contact us at pbps_support_team@optum.com.
Users can expect minimal interruption while using the SmartPay Plus application. If any interruptions occur, please contact our support analysts to report any issues or concerns.
Best Regards,
SmartPay Plus Support
Posted Jun 26, 2025 - 13:52 EDT
This scheduled maintenance affected: SmartPay Plus.