Welcome to our new simplified view of this Optum Solution Status page making it easier for you to quickly get the information you need.

Resolved Notice- RXNS ERX - Rx Connect (Switch) Cloudflare update regarding rxnsconnect.changehealthcare.com

Incident Report for Optum Solutions

Resolved

Optum Insight migrated to Cloudflare for connectivity to rxnsconnect.changehealthcare.com effective date March 2, 2026. Some pharmacies experienced intermittent connectivity issues. Technical staff worked diligently to resolve the issue. The issue was resolved at 4:18pm CST 3-6-2026.

#INC48787011
Posted Mar 06, 2026 - 18:12 EST

Update

Optum Insight migrated to Cloudflare for connectivity to rxnsconnect.changehealthcare.com effective date March 2, 2026. Some pharmacies experienced intermittent connectivity issues. Technical staff worked diligently to resolve the issue. The issue was resolved at 4:18pm CST 3-6-2026.


#INC48787011
Posted Mar 06, 2026 - 18:11 EST

Update

Some customers may continue to experience intermittent connectivity errors when connecting to rxnsconnect.changehealthcare.com. The technical teams are actively working to resolve the issue. We will provide further updates as more information becomes available by 5 PM CST.

#INC48787011
Posted Mar 06, 2026 - 15:58 EST

Update

Some customers may continue to experience intermittent connectivity errors when connecting to rxnsconnect.changehealthcare.com. The technical teams are actively working to resolve the issue. We will provide further updates as more information becomes available by 3 PM CST.

#INC48787011
Posted Mar 06, 2026 - 14:12 EST

Update

Some customers may continue to experience intermittent connectivity errors when connecting to rxnsconnect.changehealthcare.com. The technical teams are actively working to resolve the issue. We will provide further updates as more information becomes available by 1 PM CST.

#INC48787011
Posted Mar 06, 2026 - 12:09 EST

Update

Some customers may continue to experience intermittent connectivity errors when connecting to rxnsconnect.changehealthcare.com. The technical teams are actively working to resolve the issue. We will provide further updates as more information becomes available on 3-6-2026 by 11 am CST.


#INC48787011
Posted Mar 05, 2026 - 20:08 EST

Investigating

Optum Insight migrated to Cloudflare for connectivity to rxnsconnect.changehealthcare.com effective date March 2, 2026. Some pharmacies may have intermittent connectivity issues. Technical staff is activity working to resolve any issues. If you experience any timeouts and your organization does IP filtering, you will need to whitelist for outbound traffic IP Subnet 168.183.3.128 /27 (usable range 168.183.3.128-168.183.3.159). If continue to see issues please report to your software vendor or call our customer support team at: 866-379-6389.

#INC48787011
Posted Mar 05, 2026 - 18:13 EST
This incident affected: Pharmacy Solutions (Pharmacy Network Solutions).