For further updates about the Change Healthcare cybersecurity issue, please visit Change Healthcare Cyber Response.

For imaging solutions, please visit us at Change Healthcare Enterprise Imaging.

Resolved:MedRx claim timeout and website issues.
Incident Report for Optum Solutions
Resolved
The issue identified on Jan. 8, 2025, has been resolved. Optum identified an issue causing intermittent timeouts for claims submitted to MedRx Medicare as well as intermittent tool issues on the MedRx website.

We will continue to monitor systems to ensure that there is no recurrence of the issue.

REF 15770211
Posted Jan 08, 2025 - 12:26 EST
Investigating
Jan. 8, 2025, Optum has identified an issue causing intermittent timeouts for claims submitted to MedRx Medicare as well as intermittent tool issues on the MedRx website. We are currently working to resolve these issues and will provide an update as soon as possible.

REF 15768508 1/8/2025
Posted Jan 08, 2025 - 10:09 EST
This incident affected: Pharmacy Solutions (MedRx, MedRx Commercial, MedRx Flu, MedRx Medicare, MedRx Medicaid).