For further updates about the Change Healthcare cybersecurity issue, please visit Change Healthcare Cyber Response.

For imaging solutions, please visit us at Change Healthcare Enterprise Imaging.

SmartPay Historic Data Unavailable after April 30, 2025
Scheduled for Apr 30, 00:00 - 00:05 EDT
Update
Reminder: Effective April 30, 2025, historic SmartPay transaction data will no longer be available. After this date we will not be able to support any requests for transaction data.

All transaction data requests must be submitted by March 28, 2025, to bipharmacy@optum.com to allow adequate time to be processed.

Questions can be directed to bipharmacy@optum.com.

REF 15682769
Posted Jan 22, 2025 - 16:16 EST
Scheduled
Effective April 30, 2025, historic SmartPay transaction data will no longer be available. After this date we will not be able to support any requests for transaction data.

All transaction data requests must be submitted by March 28, 2025, to bipharmacy@optum.com to allow adequate time to be processed.

Questions can be directed to bipharmacy@optum.com.

REF 15682769
Posted Jan 03, 2025 - 11:00 EST
This scheduled maintenance affects: Provider Communications and Payment Services (SmartPay Plus for Providers).