Welcome to our new simplified view of this Optum Solution Status page making it easier for you to quickly get the information you need.

Optum Rx Timeouts

Incident Report for Optum Solutions

Resolved

This incident has been resolved.
Posted Oct 30, 2025 - 11:54 EDT

Investigating

The Processor Optum Rx is experiencing sporadic connectivity issues starting Monday Oct. 20, 2025. Optum Insight Rx Connect switch service may be impacted.
Optum Rx is working on a resolution. Optum Insight switch is closely monitoring this issue.
Posted Oct 22, 2025 - 18:00 EDT
This incident affected: Pharmacy Solutions (Pharmacy Network Solutions).