Welcome to our new simplified view of this Optum Solution Status page making it easier for you to quickly get the information you need.

Resolved Notice: MEDICAL NETWORK REALTIME - Issues with Optum systems due to an AWS service interruption

Incident Report for Optum Solutions

Resolved

At this time we believe all services have been restored. Both the Optum and AWS teams are continuing to monitor for any residual issues, but as of 4:20 pm CDT we are seeing typical performance and success rates.


INC/CSA/Ref# INC46073520
Posted Oct 20, 2025 - 17:21 EDT

Monitoring

Most AWS services and internal systems have shown substantial recovery, with numerous previously impacted servers now operating normally following manual interventions and configuration adjustments. AWS continues to issue updates, and the support teams remain vigilant, actively monitoring for any residual or emerging issues as recovery efforts progress.
Posted Oct 20, 2025 - 16:43 EDT

Update

Team is still waiting on resolution from AWS. An update will be shared within the next hour.

INC/CSA/Ref# INC46073520
Posted Oct 20, 2025 - 15:28 EDT

Identified

Team is still investigating the issue and will update you as soon as their are any changes.

INC/CSA/Ref# INC46073520
Posted Oct 20, 2025 - 14:25 EDT

Investigating

We are currently experiencing intermittent performance issues with Optum systems due to an AWS service interruption. As a result, Connect Center, Enrollment Central, Real-time clearinghouse transaction processing, and call center phones are experiencing sporadic connectivity and performance


INC/CSA/Ref# INC46073520
Posted Oct 20, 2025 - 13:21 EDT
This incident affected: Medical Network (Real Time).