For further updates about the Change Healthcare cybersecurity issue, please visit Change Healthcare Cyber Response.

For imaging solutions, please visit us at Change Healthcare Enterprise Imaging.

Resolved :Clinical Decision Support

Incident Report for Optum Solutions

Resolved

We are pleased to inform you that the issue affecting the InterQual Cloud Solutions applications has been resolved. Users should no longer encounter errors when selecting content. Thank you for your patience and understanding while we worked to resolve this matter. If you continue to experience any issues, please do not hesitate to contact our support team.
Posted Feb 28, 2025 - 23:21 EST

Investigating

We are currently investigating an issue affecting the InterQual Cloud Solutions applications. Users may encounter errors when selecting content. Our team is actively working to identify and resolve the problem. We will provide additional information as our investigation progresses.

Thank you for your patience and understanding.

INC# INC0693608
Posted Feb 28, 2025 - 22:57 EST
This incident affected: Clinical Decision Support (InterQual® AutoReview, InterQual® Cloud Solutions).