Welcome to our new simplified view of this Optum Solution Status page making it easier for you to quickly get the information you need.

Resolved Notice: Clinical Exchange - MFA and printing Issues related to maintenance

Incident Report for Optum Solutions

Resolved

The issue is fixed.

INC#INC48489210
Posted Feb 18, 2026 - 10:06 EST

Investigating

We are aware of an issue affecting Clinical Exchange and are currently working toward a resolution.

INC#INC48489210
Posted Feb 18, 2026 - 09:36 EST
This incident affected: Clinical Exchange.