Welcome to our new simplified view of this Optum Solution Status page making it easier for you to quickly get the information you need.

Resolved: MEDRX AZURE CHC : Optum Insight's Pharmacy Help Desk is facing intermittent phone issues due to a major internet outage at a telephony provider

Incident Report for Optum Solutions

Resolved

Calls are currently connecting successfully without any issues. We will continue to monitor the situation closely.
Posted Oct 20, 2025 - 16:32 EDT

Update

The team is currently conducting a thorough investigation into the issue and is actively working toward a resolution. A status update will be communicated within the next hour.
Posted Oct 20, 2025 - 16:11 EDT

Monitoring

The team is actively investigating the issue and working toward a resolution. An update will be shared within the next hour.
Posted Oct 20, 2025 - 14:52 EDT

Identified

Team is still investigating the issue and and will update you as soon as their are any changes.
Posted Oct 20, 2025 - 13:26 EDT

Investigating

[10/20/2025] 11:30 AM EST

Optum Insight's Pharmacy Support Help Desk is currently experiencing intermittent telephone connectivity issues due to a large scale Internet outage for one of our telephony providers. We are working diligently to restore this connectivity and will update you as soon as their are any changes.


INC46079060
Posted Oct 20, 2025 - 11:32 EDT
This incident affected: Pharmacy Solutions (MedRx).