Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 13, 2025 - 20:00 EDT
Scheduled
This message is intended for InterQual® Customize customers.
We are pleased to announce the March 2025 release of InterQual® Customize, which includes these updates:
• Fixed an issue where the properties panel truncated certain fields during searches • Removed a false validation error indicating that “Criteria Point description is required”
These changes will be deployed to the production environment on Thursday, March 13, 2025, between 8 p.m. ET and 9 p.m. ET. The application will be available while these updates are deployed, though users may experience degraded performance during the maintenance window.
Contact Information For additional information or assistance, sign in to the Customer Care Hub and submit a new case to Product Support.
REF 16838888
Posted Mar 13, 2025 - 10:11 EDT
This scheduled maintenance affected: Clinical Decision Support (InterQual® Customize).